文章目录
- 环境
- 症状
- 问题原因
- 解决方案
环境
系统平台:Linux x86-64 Red Hat Enterprise Linux 8
版本:4.5.8
症状
hgdb安全版458创建dblink报错
create extension dblink ERROR: syntax error at or near "TYPE" 时间: 0.006s问题原因
将关键字 type 配置到flatten_keyword_list参数中,关键字变为普通标识符。
解决方案
参数解释
flatten_keyword_list:可配置任意关键字到此列表中,被配置的关键字会被当做普通的标识符识别,当关键字被识别成普通字符时,有些需要关键字的语法也就不能被识别。
session_restore_keyword_list:可配置任意关键字到此列表中,被配置的关键字与flatten_keyword_list冲突时,冲突关键字不会退化成标识符。当前会话再恢复为关键字加到这个列表。
方法一:去除flatten_keyword_list中关键字
vi postgresql.auto.conf flatten_keyword_list='xxxx,copy,xxxx' 修改为 flatten_keyword_list='xxxx,xxxx' psql -U sysdba select pg_reload_conf()方法二:session_restore_keyword_list 中添加关键字
vi postgresql.auto.conf flatten_keyword_list='xxxx,copy,xxxx' session_restore_keyword_list='copy' psql -U sysdba select pg_reload_conf()